Notice: We are now selling NEW Gelbooru Merch~! Domestic shipping is free on all orders! Do you have an artist tag on Gelbooru? Let us know so we can properly credit you!

Ticket Information - ID: #1016

ID:Category:SeverityReproducibilityDate SubmittedUpdated By:
0001016Bug Reportingnormalalways05/13/20 05:24AMlozertuser
Assigned to:geltas
View StatusPublic
Target Version:N/A
Summary:Certain pictures can't be uploaded
Description:There are very few pictures that can't be uploaded for some reason and I end up getting an ERR_HTTP2_PING_FAILED timeout when trying.

Here's an example:

Maybe the server doesn't know what to do with it for some reason or fails to show a message about what's wrong with it?

I already tried to strip its metadata or resave it in another file format.
I also waited a day before reporting in case it's something temporary.

Uploading most other pictures works just fine, it's just very few ones giving trouble (like 2 out of 40, both directly taken from pixiv).
Additional Info:
Chytharo replied at 2020-05-14 08:53:12
Just tried again and it worked now for whatever reason.
Would still be good to know what causes some pics to not upload properly for 1-2 days.
I will continue to do some uploading now and I will make sure to update the ticket in case I encounter the issue again.

lozertuser replied at 2020-05-14 21:36:42
I think it has to do with GZIP on our content, but I'm not entirely sure. I didn't change anything either.

Chytharo replied at 2020-05-17 21:19:02
Here's another one I currently can't upload:

lozertuser replied at 2020-05-18 00:17:26
Check your DNS settings, it may be you aren't using a custom DNS and the server you were using was down.

lozertuser replied at 2020-05-18 09:47:57
Also need to know what browser you are using + version.

Chytharo replied at 2020-05-18 14:15:46
Yeah, I'm using the automatic DNS. Which DNS should I use for trying again?
I'm using Opera 68.0.3618.63

So, it is an issue on my end?

lozertuser replied at 2020-05-18 23:27:12
Not sure yet. Try using Google DNS (, or Cloudflare DNS (

lozertuser replied at 2020-05-18 23:33:41
Also, I believe opera is around .68 now, but I'm not sure if there were any bug fixes that may be relevant to your issue. I'll be testing opera hopefully tomorrow morning to see if it's a specific problem with that browser, or just you.

Chytharo replied at 2020-05-19 07:44:39
Updated Opera to 68.0.3618.104 - Issue still present
Changed DNS to Google Server - Success!

So it was my IPS's DNS fault then, good to know.
Is it safe to just let it stay on Google's DNS or should I switch just for uloading? I'm asking because they could theoretically log my entire internet activity.

Anyways, since it seems not to be an issue on Gelboorus side, consider this ticket as resolved :)

lozertuser replied at 2020-05-19 14:29:13
You may want to use your own DNS server, which you could in theory install on your computer, or just use Cloudflare which supports DNS encryption. I'm sure DDG will come out with their own as well if one isn't out already.

lozertuser replied at 2020-05-19 14:32:51
Also, if you suddenly can not access websites down the line, revert to your ISP's DNS server as they may be requiring you to read something forcefully through your browser.