Gelbooru

Notice: Visit your account options to access your Patreon rewards for March. Come join our Discord! Since switching to SSL only we have noticed a decrease of 20 load. Please contact us if your code stopped working!

Ticket Information - ID: #300


ID:Category:SeverityReproducibilityDate SubmittedUpdated By:
0000300Bug ReportingHighalways11/23/09 02:25AMJerl
Reportersalarta
Assigned to:geltas
Resolution:Resolved
View StatusPublic
Version:0.2.0
Target Version:0.2.0
Summary:'My Tags' in Upload screen that have apostrophes lead to a tag search
Description:Clicking on a tag with an apostrophe (') in its name in the My Tags section of the Upload screen leads to a search of the tag rather than its addition to the 'Tags' portion of the same screen.
Additional Info:I first noticed this problem when I added demon's_souls to my My Tags. I also tested 'frankenstein's_monster', which had the same problem, then reduced it to 'frankenstein' to test if anything after demon's_souls would have the same problem, to which 'frankenstein' successfully added to the 'Tags' part of the screen. As far as I've seen, the problem is limited to any tags with an apostrophe in them.

It's not urgent (as far as I can see it anyway) because the tag can still be manually typed into the field, so I listed it as a low priority.
salarta replied at 2010-08-11 13:27:44
This has been listed as resolved, but the problem is still occurring.

More importantly, I just added an artist with an apostrophe in their name and it appears their Artists entry is either inaccessible or takes a long time to load (clicking on a different artist entry, it loads right away). It also doesn't show the artist as having any pictures on gelbooru.

lozertuser replied at 2010-08-12 04:10:24
The fix must have been reverted for some reason. It should be working fine now.

salarta replied at 2010-08-12 07:44:03
It works now. There's still some small issue with Artist entries with an apostrophe though. Entries with an artist with an apostrophe take a little longer to load (I did let me see it eventually though) and they don't show pictures the artist did within the entry. That might not be a big deal to you guys though, not sure, since you can still access the artist's information. Either way, thanks for the help.

usernam replied at 2016-03-25 01:29:46
This same issue of my tags links going to tag search also happens at the &id= pages

Jerl replied at 2016-04-02 13:24:25
The tag links literally do point to the tag search page. It's just that there's JavaScript that grabs the click first and makes changes to the textbox instead.

Do you have JavaScript disabled?