Gelbooru

Notice: Visit your account options to access your Patreon rewards for June. Do you have an artist tag on Gelbooru? Let us know so we can properly credit you!

Ticket Information - ID: #881


ID:Category:SeverityReproducibilityDate SubmittedUpdated By:
0000881Bug Reportingnormalalways04/14/17 06:13PMsurveyork
Reportersurveyork
Assigned to:geltas
Resolution:Open
View StatusPublic
Version:0.2.5
Target Version:N/A
Summary:Upload/Edit post: Clicking on a bold tag searches for that tag instead of removing it
Description:When uploading or editing a post, clicking on a tag from "My tags" highlights it (bold font) and adds it to the post. Clicking on a highlighted tag from "My tags" should remove it. Instead, Gelbooru 0.2.5 opens the search page for that tag instead of removing it.
Additional Info:Steps to reproduce:

1. Make sure you have the tag "1girl" in My Account > Options > My tags.
2. Open any post and click on edit.
3. On "My tags", click on "1girl": "1girl" is added to the post. "1girl" is highlighted in bold in "My tags".
4. Click again on "1girl", highlighted in bold within "My tags".
5. The search page for "1girl" opens ( https://gelbooru.com/index.php?page=post&s=list&tags=1girl ).

Expected results:

Clicking on a highlighted (bold) tag from "My tags" should remove that tag.

Actual results:

Clicking on a highlighted (bold) tag from "My tags" opens the search page for that tag.
Jerl replied at 2017-04-14 18:29:20
Been trying to get lozer to fix this for weeks.

surveyork replied at 2017-04-15 00:32:38
Also, my bad: On the "Upload post" page the behavior is this: Clicking on any tag from "My tags" for the first time opens the search page for that tag. No need for the tag to be highlighted first. The result of this behavior is that "My tags" becomes useless on the "Upload post" page. :(